Version is too old to open project (forward compatibility)

Follow

We try to make sure that Migri is backward compatible in the sense that new releases of Migri can load old projects.

 

Many new projects can also be loaded by old releases of Migri, but Migri is not always forward compatible. When new projects makes use of features that were not present in older versions of Migri, the forward compatibility will be broken, and Migri may present the user with a message similar to:

 

The version you are using is too old for this project. See Troubleshooting at Help/OnlineSupport for more info.

 

The Project will then not be loaded into Migri. Sometimes you may still want to load the projects into the older version of Migri. This can be done by repeatedly trying to load the project - a minimum of 5 times - until it loads into Migri. After doing this, we recommend that you check what the issue may be. This you may do by writing in the command window:

 

im Project.info Project.requires

 

one of more numbers in the form of YYMMDD, e.g. 210311 may be listed, each representing a date where a new feature that is required by the project was added. At the present time, the following new feature dates exist:

 

170914: New default lithology parameter values not supported by pre 1.5.6 releases

190410: ENI lithologies not supported by pre 1.8.0 releases

190810: Modified ENI lithologies not supported by pre 1.8.2 releases

210311: Baur 4 component kinetics added to the Migri 2.0.0 release. Migri 1 series can not model with multicomponent kinetics, but you can change from Baur to Pepper kinetics in order to simulate the model.

 

Have more questions? Submit a request

Comments